Skip to main content

Changelog

September 2026

  • Threw the pair of 256 GB SATA SSDs I had lying around into optiplex-vault, I'll probably make them hold some swap and migrate VM storage to them?
  • VM started slowing down again, I was finding journald timing out and being killed by the watchdog. Seems like disk bandwidth was thrashing around a lot, but it's hard to catch in the moment.
    • I added a dropin to /etc/systemd/jounald.conf.d to set a lower burst rate limit in case of overwhelming amounts of log messages coming in, but I'm not sure that'll have much impact
  • Yunohost VM was taking a long time to respond when loading any service, so had to investigate
    • The VM was throwing kernel messages about the ATA driver failing to perform a cache operation
    • changed the VM ata device cache mode to writethrough
    • This seems to have fixed the problem for now.

August 2026

  • gitea stopped working, I was unable to authenticate - turns out the postgres server had stopped probably due to an update and the service unit not being configured to restart after a clean shutdown. Edited postgresql@.service to use Restart=always
    • I was worried this would be some obscure incompatibility with the NGINX configuration that attempts to rate-limit clients continuously hitting the login page, but no. It was a 500 error from gitea, so we were reaching the service container successfully.
    • Gitea logs indicated failure to reach the database running on optiplex-vault.

June 2026

  • configured gitea email sending with SMTP through purelymail
  • fixed Jellyfin cache capacity which was causing the startup to fail
    • relocated cache and data directories to /home/jellyfin
    • updated paths in /etc/default/jellyfin which is the environment file for the systemd service
  • set up wireguard VPN interface on Optiplex-vault with systemd-networkd following guidance from https://wiki.archlinux.org/title/Mullvad
  • fixed yunohost-vm DNS by adding my local DNS server to the top of /etc/resolv.dnsmasq.conf and reboot
  • fixed DNS issues - I had followed some steps that uninstalled systemd-resolved package which wasn't very nice
  • migrated Jellyfin from docker host VM to optiplex-vault directly